Swoole Compiler 安装向导

(RiPro需要Swoole Compiler加密扩展,支持PHP5.6~7.4,推荐7.4)

环境信息

  • 操作系统 : Windows NT MYfgCo1001024 6.1 build 7601 (Windows Server 2008 R2 Datacenter Edition Service Pack 1) AMD64
  • PHP版本 : 5.6.40
  • PHP运行环境 : cgi-fcgi
  • PHP配置文件 : D:\BtSoft\php\56\php.ini
  • PHP扩展安装目录 : ext
  • PHP是否线程安全 : 非线程安全
  • 是否安装swoole_loader : 未安装
  • 温馨提示:当前环境使用的PHP为 32 位的PHP,Compiler 目前不支持 Debug 版本或 32 位的PHP,可在 phpinfo() 中查看对应位数,如果误报请忽略此提示

安装和配置Swoole Loader 扩展

    1 - 点击下载 windows PHP5.6 Swoole Loader扩展文件

    2 - 安装Swoole Loader

    将刚才下载的Swoole Loader扩展文件(php_swoole_loader_php56_nzts_x64.dll)上传到当前PHP的扩展安装目录中:ext

    3 - 修改php.ini配置(如已修改配置,请忽略此步骤,不必重复添加)

    编辑此PHP配置文件:D:\BtSoft\php\56\php.ini
    在此文件底部结尾处加入如下配置并且保存 :extension=php_swoole_loader_php56_nzts_x64.dll
    注意:需要名称和刚才上传到当前PHP的扩展安装目录中的文件名一致

    4 - 重启PHP或者重启服务器